WorldEdit を Minecraft1.7.10 で使いたいけどBukkitとか分けがわからない人の為の文書

7月 28th, 2014 § 10 comments

世の中には WorldEdit という素晴らしい Minecraft の Mod があるらしいけど、何度解説を見ても導入の仕方が分からないとか、前のバージョンでは導入できたけどマイクラがバージョンアップしたら出来なくなったとか。どうしてもシングルプレーで WorldEdit が使いたい人とか、そういう人向けの Bukkit を導入しないで WorldEdit を使う方法について。ただし、色々がっつり導入したい人はやっぱり Bukkit を使うのが一番出来る事は多い。

簡単に最新版のマイクラのシングルプレーで WorldEdit が使える WorldEditWrapper

wewrapper_header

WorldEditWrapper は導入が簡単だと思うので今まで失敗してた人にも結構お勧めできる上に、最近のバージョンアップも多いのでシングルプレーで WorldEdit が使いたい人にも向いてると思う。

WorldEditWrapper のインストールの仕方

  1. LiteLoader をインストールする
  2. WorldEditWrapper litemod をダウンロードして .minecraft にある mods フォルダの自分が使う Minecraft のバージョンのフォルダに入れる
  3. 終わり

インストール後に、LiteLoader で起動したい時は profile を liteloder と書かれている奴にする必要がある。LiteLoader の profile で起動すると WorldEdit が読み込まれる。追加で WorldEditCUI も入れたい人は入れることが出来る。

LiteLoader のインストールの仕方

liteloader_header_han

LiteLoader の WorldEditWrapper あわせたバージョンをダウンロード。この時 Windows なら exe 版をダウンロードすれば、後はダウンロードしたのをダブルクリックするだけでインストールできた気がする。ただし、Forge や Optifine と同時に導入したい場合は注意が必要。この辺のちょっと組み合わせが必要な事をしたいなら自分でフォーラムを読んで確認してやると良いと思う。

過去に導入で一度躓いた事がある人向け

例えば、シングルプレーで過去に SPC(SinglePlayerCommand)で導入していた人。Forge で WorldEdit を導入していた人。でも何故かバージョンをあげると動かなくなってしまった人。そもそも Forge の WorldEdit が Minecraft 1.7.10 に対応してなくてアップデートできない人など向け。まず躓いた人は以前の残りカスが出て動かなくなるといけないので、その対処をしないといけない。特にインストールのやり方を見てバージョンアップを試してもエラーが出たりクラッシュしてしまってアップデートが出来ない人は

C:\Users\ユーザー名\AppData\Roaming\.minecraft\

このフォルダに mod とか coremod というフォルダが無いかチェック。そのフォルダに入っている古いバージョン用の mod が入っていると起動時に読み込まれてしまいバージョンが合わないのでクラッシュしたりエラーが出たりする。もしその古いバージョンの mod がもう必要ない人は削除。取っておきたい人はどこかにバックアップ。

古いバージョンの mod を混同させたくない人向けの話

古いバージョンの mod も残しておきたいという人は、マインクラフトを起動させると出てくるランチャーの左下辺りにある「Edit Profile」ボタンで Profile を編集する。編集したい古いプロファイルを選び「Edit Profile」ボタンを押すと「ProfileEditor」が出てきて下のような画面になる。
ProfileEditor
注目する場所は「Game Directory:」で、横にあるチェックボックスにチェックを入れて、C:\Users\ユーザー名\AppData\Roaming\.minecraft\versions\1.7.10-Forge10.13.0.1188 などのような使いたい Forge や Modloader の version のフォルダを指定し「Save Profile」で保存。次にその保存した Profile で起動すると、「Game Directory:」で指定したフォルダにセーブデータや mod のフォルダが作られて version 毎に mod のフォルダを分けることが出来き、バージョン違いの mod によるクラッシュを防げる。勿論セーブデータのフォルダも変わるので、データをそちらに入れないと編集できなくはなるが、古いバージョンの mod 環境をそのまま保存しておく事が出来る。

私は個人的には mod を基本的に使わない人なので、それぞれの Mod 特有の症状の場合の対処の仕方は分からない。このやり方は、そんな複雑な事はする気はないし出来そうにないから、単に WorldEdit を使いたいだけという人には向いてる。それ以外の人は Bukkit が逆に選択肢が多くて楽だと思う。

WorldEditWrapper 公式フォーラムのスレッド

WorldEditWrapper – use WorldEdit in Single Player – Minecraft Mods – Mapping and Modding – Minecraft Forum – Minecraft Forum
http://www.minecraftforum.net/forums/mapping-and-modding/minecraft-mods/1294341-worldeditwrapper-use-worldedit-in-single-player

関連項目

WorldEdit のコマンドが覚えられない人の為の文書
http://minecraft.ologies.net/2014/08/worldedit-command/
WorldEdit と MOD を組み合わせて使うとできる事
http://minecraft.ologies.net/2014/08/worldedit-mod/
WorldEdit の選択範囲を表示する 「WorldEditCUI」
http://minecraft.ologies.net/2014/07/worldedit-worldeditcui/
「Macro / Keybind MOD」
http://minecraft.ologies.net/2014/07/macro-keybind-mod/

Tagged , , , , , , , , , , , ,


  • Related Posts

  • § 10 Responses to WorldEdit を Minecraft1.7.10 で使いたいけどBukkitとか分けがわからない人の為の文書"

    • まゆ1226 より:

      このやり方を使っても起動できませんどうしたらよいですか。ちなみにデモ版です。

      • 匿名希望 より:

        なぜデモでやろうとしたww製品版でやって下さい

      • admin より:

        残念ですが、デモ版では多分動かないと思います。PC 版以外の Minecraft でも多分動きません。

    • 匿名 より:

      書いてある通りにライトローダーをインストールしてバージョンの中に.zipのままいれたのですが適用されません。どうしたらよいでしょうか。
      forgeも入っており、バージョンは1.7.10です。

    • 匿名 より:

      自己解決しました。ダウンロードしたファイルの拡張子をzipからjarに変えて、modsフォルダに入れるとできました。

      • admin より:

        jarで動くのはforgeのプラグインではないかと。liteloaderは.litemodという拡張子になっているような気がします。どちらも同じmodsフォルダに入れれば動きます

    • ddd より:

      できません。どうすればいいですか?
      書いてあるとうりに、1.7.10のバージョンの中に.zipのままいれたのですが適用されません。どうしたらよいでしょうか。
      forgeも入っており、バージョンは1.7.10です。

      • admin より:

        上のコメントでも書いたのですが、.zip というのが少しおかしいかと。WorldEditWrapper は公式からダウンロードすると.litemod という拡張子で配布されているので、zipのファイルではありません。もし、WorldEditWrapper の話でしたら公式からダウンロードしなおした方がいいかと思います。

        worldeditwrapper
        http://www.liteloader.com/mod/worldeditwrapper

        forge の mod 関しては forge と同様に jar ファイルで入れれば動くはずです。

    • ddd より:

      できました!ありがとうございます!

    • sukai1000 より:

      WorldEditのforge版が出てますよ。

    コメントを残す

    メールアドレスが公開されることはありません。

    URLが多数含まれる投稿は無視されます。

  • Minecraft ologies

  • Recent posts

  • RSS Minecraft Update News

  • Categories

  • What's this?

    You are currently reading WorldEdit を Minecraft1.7.10 で使いたいけどBukkitとか分けがわからない人の為の文書 at minecraft.ologies.net.

    meta

  • Tag